825i fuel gauge issues... - John Deere Gator Forums
Gator General Discussion If you need to talk about the John Deere Gator XUV/SXS/UTV and it does not fit into a more specific section down below, post it in here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-08-2019, 04:33 PM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 4
 
825i fuel gauge issues...

Have a 2013 825i thats having issues with the fuel gauge not working. This machine has the digital level indicator in the dash. When I first turn the key on the gauges cycle and the fuel level shows completely full and then goes back down to empty. The old level gauge I took out of the tank was part # AM142388 and the new one is AM144939. They are the same dimensions but the new one has a black float around the outside of it that you can move by hand. Looking for any ideas or things to check why its always showing empty. Im guessing worst case is the gauge itself is bad? Thanks
Tyler Cohrs is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-09-2019, 06:53 AM
Senior Member
 
Join Date: Nov 2014
Location: PA
Posts: 572
 
Perhaps you can connect your voltmeter to the float and verify the resistance changes through its range and matches the factory specification as a starting point to the diagnostics.

2012 JD855D OPS Black Poly Roof, Deluxe Cargo Box, Front and Rear Protection, Power Lift, Front Hood Rack, Rear Screen (homemade), 800 Watt Inverter, 2500lb Winch installed in cargo bed, Front and Rear LED auxiliary lighting (4" square 27 watt), Front and Rear CV Guards, Koplin Side Mirrors
200mph is offline  
post #3 of 4 Old 06-13-2019, 06:03 PM
TKD
Junior Member
 
Join Date: Feb 2018
Posts: 4
 
I also have a 2013 825i that had the same exact problem. Replaced the sending unit, and solved the issue. FYI...the new sending unit is different from the old unit. Hooks up the same.
TKD is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 06-17-2019, 07:49 AM
Senior Member
 
Join Date: Nov 2014
Location: PA
Posts: 572
 
So what did the OP find or do to remedy the situation?

2012 JD855D OPS Black Poly Roof, Deluxe Cargo Box, Front and Rear Protection, Power Lift, Front Hood Rack, Rear Screen (homemade), 800 Watt Inverter, 2500lb Winch installed in cargo bed, Front and Rear LED auxiliary lighting (4" square 27 watt), Front and Rear CV Guards, Koplin Side Mirrors
200mph is offline  
Reply

  Lower Navigation
Go Back   John Deere Gator Forums > John Deere Gator General Discussion > Gator General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the John Deere Gator Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome