RSX 850i will not start - John Deere Gator Forums
Gator RSX850i Discuss John Deere's all new Gator RSX850i UTV here!

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 02-26-2014, 12:07 PM Thread Starter
Member
 
Join Date: Nov 2013
Location: Moncton
Posts: 69
 
RSX 850i will not start

Parked my new gator (90 miles) last week as there is too much snow in my area to run. Went out to garage yesterday and it would not start. I checked all the fuses and connections and everything looks ok. Engine cranks but will not start. Suggestions anyone??
madorsx is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 02-26-2014, 12:37 PM
Senior Member
 
Join Date: Jun 2013
Posts: 709
 
Water in your fuel maybe? Maybe fuel solenoid isnt opening?
DeereSales101 is offline  
post #3 of 9 Old 02-26-2014, 02:36 PM
Senior Member
 
Join Date: Apr 2013
Posts: 146
 
I had a little water problem with my machine last summer. Got her dried out and all the fluids changed. Went to fire her up and had the same problem. The machine would turn over, just wouldn't fire. I had good fuel and spark, so I was stumped and took it back to Deere. Turned out to be the oxygen sensor on the lower exhaust (on the right side). If those sensors get wet and ruined, your gator ain't gonna start! Sounds like a possible culprit! Also, can you hear your fuel pump run when you first turn on the key?
Minshall is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 02-26-2014, 11:58 PM Thread Starter
Member
 
Join Date: Nov 2013
Location: Moncton
Posts: 69
 
Don't think it's a water problem - just ran it on some hard pack snow - but who knows! Dealer picking it up the morning and I'll mention the sensor and I agree - a wet sensor leaving you stranded in the middle of the woods doesn't sound that appealing. I'll post the outcome!
madorsx is offline  
post #5 of 9 Old 06-01-2014, 05:50 PM
Senior Member
 
Join Date: Apr 2013
Posts: 146
 
Did you ever find the problem?
Minshall is offline  
post #6 of 9 Old 06-01-2014, 09:23 PM
Member
 
Join Date: May 2014
Location: McMinnville, TN
Posts: 40
 
The lower right o2 sensor went bad (damaged) on my RSX and it still ran fine. The only thing I noticed was the service light on.
farmall66 is offline  
post #7 of 9 Old 10-12-2019, 02:08 PM
Junior Member
 
Join Date: Oct 2019
Posts: 1
 
My rsx 850i will not start. Light cluster comes on but fuel pump does not kick in at all. Look at connections, fuses and all appears good. Any ideas
Casca is offline  
post #8 of 9 Old 10-12-2019, 06:43 PM
Senior Member
 
Join Date: Nov 2014
Location: PA
Posts: 613
 
Quote:
Originally Posted by Casca View Post
My rsx 850i will not start. Light cluster comes on but fuel pump does not kick in at all. Look at connections, fuses and all appears good. Any ideas
You must have good vision to see the electrons flowing. The only why I can tell if current is flowing is to use a meter or test light.

Perhaps give a better account of what is happening and what you've tried so far. It's also best to start a new thread instead of replying to a 5 year old thread.

2012 JD855D OPS Black Poly Roof, Deluxe Cargo Box, Front and Rear Protection, Power Lift, Front Hood Rack, Rear Screen (homemade), 800 Watt Inverter, 2500lb Winch installed in cargo bed, Front and Rear LED auxiliary lighting (4" square 27 watt), Front and Rear CV Guards, Koplin Side Mirrors
200mph is online now  
post #9 of 9 Old 10-12-2019, 11:43 PM
Senior Member
 
טים ירושלמי's Avatar
 
Join Date: Sep 2018
Posts: 344
 
Quote:
Originally Posted by Casca View Post
My rsx 850i will not start. Light cluster comes on but fuel pump does not kick in at all. Look at connections, fuses and all appears good. Any ideas
Without ever having worked on one of these.

Afaik the fuel pump should kick in no matter what but i have seen other john deere equipment that shuts off even the fuel pump when a safety switch does not work.

So thats something to check.
And yes get a testlight to check fuses because simply checking them by eye is not enough
Or ofcourse its a broken wire or bad connector somewhere.
Yes i have seen connectors that looked good but did not let any power go through.
Again: testlight

(Story:we had a new mechanic looking for an electric problem once.
Could not find the problem even though he checked everything.
Asked him Where his testlight was and he said he could work without and check all connectors and fuses.
Long story short i told him to get me a testlight ran it over the fuse panel 5 seconds and it simply had a burnt fuse.)
טים ירושלמי is online now  
Reply

  Lower Navigation
Go Back   John Deere Gator Forums > John Deere Gator General Discussion > Gator RSX850i

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the John Deere Gator Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
625I Crank no start VCLM Gator General Discussion 3 08-01-2019 10:02 AM
rsx want start Trey Gator RSX850i 8 02-26-2014 08:21 PM
Gator 4x6 diesel won't start Feedmetwinkies Gator General Discussion 7 11-09-2013 10:33 PM
Real squeal on start up!! robertifly Gator Performance Modifications 3 09-11-2012 11:05 PM
1994 Gator Won't Start bsienkowski New Member Introductions 0 04-23-2012 08:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome