John Deere Gator Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Just installed new Bosch injectors and new fuel filter. Reason for new injectors was because it was hard to start after warming up. Now it starts better than ever. Warm or cold. But now it sputters and cuts out and I can only get 38 mph out of it. Before it ran 43 mph. Also after parking it I notice what looks to like oil or hydraulic fluid on the floor under the motor. It ran great before other than starting problem after warming up. Any ideas?
 

·
Registered
Joined
·
1,519 Posts
Poor fuel quality or delivery? Maybe fuel quality was the reason the fuel injectors were suspect. Did you test the old ones to verify the spray pattern was poor or just swap parts and hope for a fix?

Spark integrity can also be an issue.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3 (Edited)
Just changed injectors hoping for fix. I’m not a mechanic. Hoped this would solve my problem. It did but now more problems. I use premium fuel only.
 

·
Super Moderator
Joined
·
3,356 Posts
Premium fuel with ethanol or Premium fuel without ethanol ? There is a difference.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5 (Edited)
Not sure. Took it for a ride earlier and it would start cutting out when I stepped on the gas pedal and 38 was top end. Constantly cutting out. Idles great. Starts great. Would spark plugs be next step?
 

·
Registered
Joined
·
7 Posts
Agree with above. I would pull injectors and look for a bad seal if now you're leaking oil. Change plugs and plug wires. Double check fuel filter installed in correct direction. Both fuel and ignition can effect engine performance. Lastly, put a small bottle of heat or fuel treatment in the tank.
 

·
Registered
Joined
·
7 Posts
In addition, your fuel pump should run with key to "ON". Then it should shut off when the system is pressurized. (engine not running) if it does not shut off suspect a leak or bad pump.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #10
Putting original injectors back in today. It’s better to deal with hard starting when it warms up than trying to trouble shoot all the problems it’s caused.
 

·
Registered
Joined
·
1,519 Posts
It will interesting to see if any new symptoms arise.

When determining root cause, structured methods require multiple swaps back and forth to prove the problem is with the parts and not the disassembly/assembly process.

Anxious to read your next post.

Good luck.
 

·
Super Moderator
Joined
·
3,356 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #13
Put old injectors back in this morning and it starts, idles and runs again 43 mph with no misses or cutting out.
 

·
Registered
Joined
·
1,519 Posts
So you're back to the original configuration, essentially doing nothing other than disassembly/reassembly and now it runs fine. Interesting!

Did you ever fix your leak mentioned in your original post?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #16
The leak turns out was not the gator. Still have the same problem as originally discussed. Hard to start after it warms up.
 
1 - 16 of 16 Posts
Top