John Deere Gator Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all. I am in need of some help with my 2008 XUV 620i #M0XUVGC21083 Gas engine 4x4. Background so far: The radiator cooling fan has stopped coming on when the engine gets really warm. The fan DOES come on when 12 volts is applied directly to the fan at the plug.. It is my understanding that the orange wire at the plug should show 12v at all times. Is that with the key on or should it be hot regardless of key switch position? At the present time there is no voltage at the orange wire with the key off or on. I have located the four relays under the dash. Three of which are attached to the firewall and the fourth is just pull tied to the main harness. Can someone tell me which one is the fan relay? I have checked all the fuses with my multi meter and all check good. One last item. Is there more than one coolant temperature switch on my unit. I found one under the intake manifold. I have NOT be able to locate one in the radiator itself. Does the one switch I found turn on the lite in the dash and the fan or am I missing a switch. I know I am asking for quite a bit of information at one time but this is frustrating as all get out. If anyone has any ideas as to where I need to start I would really appreciate your input. Thanks to all who may see this.
 

·
Registered
Joined
·
1,722 Posts
I don't have the technical manual for your model, but I know other models have two temperature sensors. One is a temperature switch to turn on the fan and the other is a thermistor that changes output with changes in temperature (typically dash indication).

When probing the fuses verify 12 volts is at fuse block. Some have found the internal receptacles where the fuses fit in to be corroded.

Might consider purchasing the technical manual to help with this and future repairs.

Good luck and hopefully someone with a similar model can assist.
 
1 - 2 of 2 Posts
Top