John Deere Gator Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Help…My new xuv590m gator was delivered yesterday and after 15mins of riding the engine malfunction light has come on. The gator has less than 1hr on it. When you shut off the engine and turn it back on the light goes out. However, after a few minutes of the engine running the light comes right back on.
Any idea as to what could be the cause? What can I do to fix it?
 

·
Registered
Joined
·
2,469 Posts
I’d be calling the dealer and not messing with it.

What does the operators manual suggest?
 
  • Like
Reactions: Dave Jr
Joined
·
9 Posts
Help…My new xuv590m gator was delivered yesterday and after 15mins of riding the engine malfunction light has come on. The gator has less than 1hr on it. When you shut off the engine and turn it back on the light goes out. However, after a few minutes of the engine running the light comes right back on.
Any idea as to what could be the cause? What can I do to fix it?
Hi Whit, I work with a casting office that is casting real owners of XUV590's for a commercial. Would you be interested in possibly appearing in a commercial with your John Deere? If so, please email us ASAP at [email protected] and I will send you the information. Thanks! Colleen
 

·
Registered
Joined
·
2,469 Posts
The number of first time poster that don’t follow up is very high. Anymore I’m hesitant to reply in detail knowing the communications is likely to be one way.

the lack of follow up hurts the quality of the forum.
 

·
Premium Member
Joined
·
68 Posts
To me it is all about helping and resolution, gators will never have the following that Polaris rangers have.We are a small bunch, i do not post to just post,i help if i can and if i need help i will ask.
 
1 - 11 of 11 Posts
Top