John Deere Gator Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
New here,am at a dead end on my 2016 625i that I purchased not running at an auction.I fairly quickly discovered the fuel pump was bad,so the local parts store fixed me up with an aftermarket one.After that it starts fine but runs rough, misses and won’t really accelerate,ran a fuel pressure test and am getting a consistent 30 psi,I need 46-49 if I’m correct.Assumed my regulator was bad but $110 later I had the same problem,so after a lot more messing around I came to the conclusion that my aftermarket fuel pump wasn’t up to the job and laid out the $150 for the John Deere one.Same problem.Could bad injectors cause this? I’ve checked them with a stethoscope and they sound good but I don’t have much experience with fuel injection systems I’m mostly learning as I go 🤓.Checking fuel pressure right at the pump to eliminate filter problems.Amp draw for the pump was 3.2 through the system and 3.6 when I bypassed directly to the battery don’t know if that is useful or not. Sorry for the long post.Any ideas greatly appreciated!
 

·
Registered
Joined
·
2,746 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
So just talked to a different service tech and he’s telling me fuel pressure for this machine should run 25-26..if he’s correct I’ve been on the wrong trail and my problem possibly lies with the throttle body.Rough idle and won’t accelerate,any suggestions?
 

·
Registered
Joined
·
2,746 Posts
All the more reason to invest in a Technical Manual to verify what is correct.

Did you check the spray pattern or verify they are all firing? Did you check spark plug wires and ignition to ensure they are providing correct spark energy when under load?

Could buy another throttle body if you think that is what it is.

Will be following to find out what the resolution is.

Happy Thanksgiving.
 
1 - 4 of 4 Posts
Top