John Deere Gator Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi everyone,


New member here. I just recently traded my early 90s JD 870 for a 2014 XUV 550. The more I try to get this thing to run half way decent the more I regret making this trade. It only has 92 hours on it.



It ran great at first and then it stalled while going through some mud (not very deep). It started right back up with no issue. Thought that was a little odd. For the rest of this little trip (probably about a mile through the woods) I had issue with it stalling randomly. By the time I got back to my house I couldn't keep it running unless I had the choke out. I parked it for about a week or so and in the mean time ordered the home maintenance kit. Changed the plugs, fuel filter and air filter. It seemed to run pretty good again, drove it around my yard for about 5 minutes and then it stalled with similar results as before, difficulty getting it to start/stay running, having to play with the choke to keep it running etc.


I suspected that it may be the fuel pump so I rigged up a small dirt bike tank zip tied to the rear seat bracket so the carburetor could be gravity fed. That seemed to help and it seemed to run well again. Then it stalled again. fiddled around with it and got it to run decent again. Then swapped it back over to the original tank setup and it still seemed to run decent. Drove it around the yard and it stalled again and now I can't get it to start at all on either tank. What's frustrating is that nothing seems to be consistent. I can't seem to pinpoint a condition in which it causes it run poorly or not run at all. The one thing that may be consistent is it stalls under heavy acceleration/load. But it doesn't seem to run decent enough for long enough to test that theory accurately.



I disconnected the fuel line going to the carburetor and cranked the engine, it would seem there is plenty of fuel volume to keep the carburetor fed. I have plenty of spark. I did not check compression given the hours, however after reading through this forum it looks like blown head gaskets are somewhat common on these engines? I also suspected an issue with what I think is the anti-backfire valve. However after removing the top engine shroud I see that someone has removed it and there is a plug in it's place. (or maybe that's factory?)


Any help you guys could offer would be much appreciated.
 

·
Registered
Joined
·
715 Posts
How do the spark plugs look? When it's idling remove the oil dipstick. Is there a normal amount of smoke coming out or does it blow pretty hard? Or, better than any of that is to perform a leak/blow down test. The early versions of these engines were very prone to blowing head gaskets. If you do need new head gaskets the replacement, upgraded are much better than the ones that came in the earlier engines.
 

·
Registered
Joined
·
866 Posts
Hi everyone,


New member here. I just recently traded my early 90s JD 870 for a 2014 XUV 550. The more I try to get this thing to run half way decent the more I regret making this trade. It only has 92 hours on it.

Since it was traded...

Did you contact the selling dealer about the issue? Certainly they did some type of presale inspection before selling it to you.;)
 

·
Registered
Joined
·
866 Posts
It would be nice if the OP gave a status update. :(
 
1 - 4 of 4 Posts
Top