John Deere Gator Forums banner

121 - 132 of 132 Posts

·
Registered
Joined
·
72 Posts
Well my faith is restored in John Deere, the service writher at dealer went to bat for me and got John Deere to pay for new primary clutch, but they wouldn't pay for labor. He contacted the dealer where I bought it and they agreed to pay half the labor so I will be left with $180.oo to pay. Not ideal but at least they paid most of it so I will remain a customer. I hope new clutch lasts longer than this one!
 

·
Registered
Joined
·
58 Posts
I have a 2014 Trail, with around 800 miles on it. Only problem I have had was a busted front diff, and that was due to a heavy foot in a sticky situation. Other than that, the machine has been flawless.
 

·
Registered
Joined
·
72 Posts
Just a follow up, the clutch and machine are working perfectly and the service mgr called just to check on how it was doing! That's great service that shows they care about their customers. I will continue to buy John Deere!
 

·
Registered
Joined
·
371 Posts
So contacted my jd dealer again about the voltage regulator fuse melting and told them that a member on here said there was a upgraded fuse block to fix this issue. So the dealer checked their system and yes jd offers a $25 fuse block that is suppose to fix this issue. Getting this covered under warranty and hope it fixes my problem.
 

·
Registered
Joined
·
210 Posts
So contacted my jd dealer again about the voltage regulator fuse melting and told them that a member on here said there was a upgraded fuse block to fix this issue. So the dealer checked their system and yes jd offers a $25 fuse block that is suppose to fix this issue. Getting this covered under warranty and hope it fixes my problem.
Did that fix it chief?

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Registered
Joined
·
371 Posts
No it didn't I gave up on the jd tech and traced the problem to water getting into on of my headlight plugs. Dried and put some dielectric silicone fixed the problem. To find it I hosed down the machine waited a hour disconnected the battery hooked my meter to the positive from the voltage regulator and to ground then pulled fuses until I found the circuit with the partial ground. From there I started checking the connections.
 

·
Registered
Joined
·
371 Posts
Also Josh I will add that if I turn on my headlights, HID's, & stereo at the same time the fuse will start to melt. But this is because I'm exceeding the 38 amps. I have been told that a dual battery setup should fix this.
 

·
Registered
Joined
·
1 Posts
Please do sir. Does it sound like a tick from a valve or a knock?
Definitely a knock. I'm hearing impaired so I had a friend (motorcycle mechanic) listen to it before I took it. He listened to it with a mechanic's stethoscope and believes it's coming from the bottom end. Still n wrd from the dealer yet. They're backlogged.
Dang..............I hate to hear that. Please let us know what the dealer says.
Did you find out what the knock was? I was riding for a few day and mine has a knock. It happens randomly but is definitely there.
 

·
Registered
Joined
·
3 Posts
I have a 2012 rsx 850i. Let me start off with the bad. I got this in 14 witch was still new and had not sold got a deal on it. When I was buying it I read reviews of how the front diffs are weak how the axels are week. clutch problems. And there was update for the primary and secondary. Plus a updat for the fuss box. The first thing to go was the e brake. And that be a problem I have been fixing three times now. They did it under warranty 2 times. That was low miles. But under stand I go 75-150 miles every time we ride. Then was the fuss panel melted and they put the 4 wire in problem gone. Then was the 4wd would not go back into 2wd. That was a seal on the plug at the front diff. Ez fix warranty. After that I lots primairy clutch and belt. The belt failed in a way that the cords in the belt jammed up the primary and the secondary clutch’s and they did the update then new clutches and belt under warranty. Deere had my back. The dash went out at 3500 miles and they put a new one in it and that came with the pcm update witch bumped my limiter to 60 they say but I’m getting 63 mph out of it.

Never had a Front differential problem. Or a axel. I have changed a few boots but that is it. It now had 3500 on it and I can’t begin to tell you how many times I have drug all makes and models sxs out the mountains and how damn hard I have been to this thing. When I say I’m hard on it that is a understatement.

Just to be up front today I litterly just ordered me a new 860 with muzzy exhaust Tuner 2” lift and a set of big horn 27” tire just like factory’s big horns. And a snorkel. I love it the early model did have a few problem but we have a Hatfield and McCoy trip plans for a week. I’m sure that will be 6-800 miles. So I will keep y’all posted on problems and how it handles.
 

·
Registered
Joined
·
22 Posts
I have had no trouble with my 2016 RSX,I run it hard in the summer and much harder in the winter.Everything from hard pack to crawling around in the deep stuff. Mileage is what it is just keep adding gas and enjoy.

Joe Garland
Yarmouth,Maine.
 

Attachments

·
Super Moderator
Joined
·
2,861 Posts
I have had no trouble with my 2016 RSX,I run it hard in the summer and much harder in the winter.Everything from hard pack to crawling around in the deep stuff. Mileage is what it is just keep adding gas and enjoy.



Joe Garland

Yarmouth,Maine.


Nice setup!
 

·
Registered
Joined
·
22 Posts
Thanks it’s been a lot of fun and I get a lot of attention every where it goes. Lots of questions and comments on the build. As you can see in the pictures always evolving, don’t know what will come next?
 
121 - 132 of 132 Posts
Top