John Deere Gator Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi guys
Like the title says, my gator will not shift into H. It will shift through all three positions and it feels like its engaging in the trans. When driven it feels like its in low. All positions work including R. I put a new belt on. It did not help. Is this a clutch issue? If so should i buy a new one or do a rebuild? I also changed the filter and fluid on the trans. its perfectly clear. (2013 RSX 850i)
Thanks in advance
 

·
Registered
Joined
·
1,579 Posts
Take the shifter cable off at transmission and see if the linkage will go into the high position or is in the detent when the shifter lever is in high. If so, maybe the cable needs adjusted.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Take the shifter cable off at transmission and see if the linkage will go into the high position or is in the detent when the shifter lever is in high. If so, maybe the cable needs adjusted.
My gator has a metal linkage arm. But yes it seems to engage in all three positions.
 

·
Registered
Joined
·
1,579 Posts
Curious if you resolved your issue and what the root cause was.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks for your response. You were the only one. Anyway. I talked to EPI and john deere. It was the clutch springs. Ordered a rebuild kit for $200 it fixed it up.
 

·
Registered
Joined
·
1,579 Posts
Awesome. Was it the primary or secondary spring that was bad?
 
1 - 7 of 7 Posts
Top