John Deere Gator Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Purchased a new XUV 550 March 15, 2012. It is used for general purpose duty around my 20 acre property. No racing. No mud running, just general transportation in the woods and fields. The unit has 42 hours on the meter.

This spring, I noticed it was not running smooth and it would occasionally stall if I left it idling. It would also stall in the first few seconds after starting it unless I played with the choke or feathered the gas pedal. Then I noticed that it seemed low on power.

It felt a bit like it was loading up and possibly running rich, although it didn't really smell rich. I checked the air cleaner and it was very clean. I suspected that the spark plugs might be getting fouled since I do a lot of short runs, lots of starts and stops and sometimes leaving it idle as I pick up branches and junk.

Took it to the local JD dealer to let them service it. They replaced spark plugs and set the valves (twice). They could not determine the cause of the poor performance. They contacted the JD tech line and were informed that the heads and head gaskets need to be replaced.

And, of course, it is now just a few weeks past the warranty period, but the dealer is trying to convince JD to cover this under warranty.

However, I am curious about the diagnosis of needing new heads. This seems like an odd conclusion unless there is a history of defective heads on these units. I don't know what troubleshooting they followed. Don't know if the unit is low on compression, etc...

Anyone know of issues? I'm open to thoughts and discussion. Thanks!
 

·
Registered
Joined
·
904 Posts
Welcome to the forum!!!!!!!! Hopefully Deere will work with you, I have had good luck with my dealer and deere even when my stuff is a few weeks out. This is the first I have heard of this issue.
 
1 - 2 of 2 Posts
Top